The issue impacting PSA integrations , automation triggers, and certain email notifications has now been fully resolved.
Our engineering team identified the root cause and implemented a fix to restore normal platform functionality.
We will continue to monitor the system to ensure stability.
Posted Mar 11, 2026 - 17:40 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 11, 2026 - 16:57 UTC
Identified
We are currently experiencing a higher-than-usual number of reports related to the following areas of the platform:
-PSA Integrations: Some users may notice delays or interruptions in data syncing with PSA integrations such as Halo, Autotask, and ConnectWise.
-Automations: Certain automation workflows may not be triggering as expected.
-Email Notifications: Email notifications for events such as document opens or status updates may not be sent or may be delayed.
Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible. We will continue to share updates on this page as we learn more.
Posted Mar 11, 2026 - 16:55 UTC
This incident affected: API servers (Integration API server).